Account Help
Need Help?

Critical System Status

Discontinued Windows XP Support

Warning: Our system shows that you are using Windows XP or older. This is a security risk. For your and the University's protection, we will require that you upgrade your Operating System to Windows 7 or newer by June 20th 2015. If this is not your computer, please inform the technical staff responsible for this computer.

If you are a Cal Poly Faculty, Staff, Student, or Affiliate and you need assistance with discovering if your computer can be upgraded or needs to be replaced, email your computer information to servicedesk@calpoly.edu.

More details